Back to overview
Degraded

Service disruption - Cloudflare outage

Nov 18 at 01:09pm GMT
Affected services
Pages
Custom Domains
Studio (cms) Dashboard

Resolved
Nov 18 at 02:55pm GMT

Cloudflare infrastructure outage affected our service between 11:48 UTC and 14:42 UTC today. This was an external provider issue impacting thousands of sites globally. Service is now fully restored. No data loss occurred.

In-depth description:
Our service experienced intermittent availability due to a global Cloudflare network failure. During this time, you may have seen 500 errors, timeouts, or pages that wouldn't load.
Timeline:
11:48 UTC - Cloudflare incident began
13:09 UTC - Root cause identified by Cloudflare
14:34 UTC - Dashboard services restored
14:42 UTC - Full resolution

This was an infrastructure provider failure outside our control. All services are now operating normally.

Created
Nov 18 at 01:09pm GMT

At 11:48 UTC today (November 18th), Cloudflare—the infrastructure provider that powers a huge chunk of the internet—had a global network failure. This wasn't just us. Thousands of sites went down, including X (Twitter), Discord, and a bunch of other major platforms you probably use daily.